RPi 3 A+



 

Innehåll.

Tillbaka till Raspbery Pi
Inledning.
Installation.
GPIO-layout.
Program.
Problem.




 


 

Här är det tänkt att beskriva Raspberry Pi 3 A+ och framför allt vad som skiljer den från tidigare modeller av Raspberry Pi.


 
 

Inledning.

Raspberry Pi 3 A+ är programmässigt bakåtkompatibel med tidigare versioner av Raspberry Pi. Hårdvarumässigt finns det en 64-bit 1.4GHz processor med 4 kärnor. Den nya RPi ska ha 10 gånger större arbetskapacitet. RPi 3 A+ är dessutom försedd med 512 MB RAM.
RPi 3 A+ är pinkompatibel samt kan köras med de "gamla" programmen för äldre RPi-modeller.

- A 1,4GHz 64-bit quad-core ARM Cortex-A53 CPU (~10x performance)
- 512MB LPDDR2 SDRAM (2x memory)
- 2 bands 802.11ac wifi (2,4 + 5 GHz)
- Complete compatibility with Raspberry Pi 1

 


 

Installation.

OBS! Det krävs versionen är 4.14 (2018-11-13) eller senare av operativsystemet (Raspbian).

För att installera operativsystemet till Raspberry Pi 3A+ rekomenderas att installationen till micro-SD-kortet görs på en annan RPi och att micro-SD-kortet sedan flyttas över till RPi2B. Det är icke nödvändigt man kan göra som vanligt.
Efter installationen ska kortet konfigureras för svenskt tangentbord, svenska språket - UTF-8 och Stockholm som tidszon. Vidare kan/bör man aktivera ssh och kamera.
Beroende på vad man ska använda Raspberry Pi till installeras:
tightvncserver. Fjärrstyra skrivbordet på RPi 3A+.
wiringPi. Det har kommit en ny version, 2.24, med några mindre anpassningar för den nya processorn.
pigpio. C-bibliotek för Raspberry Pi som tillåter kontrol av GPIO
BCM2835. RPi använder processorn 2837 men programpaketet är BCM2835.
Geany. IDE, texteditor för programutveckling.
gftp. Program för att flytta filer över internet.

 


Till början.



 

GPIO-layout.



Stiften är desamma som Raspberry Pi A, B, B+ och 3B .

 


 

Program.

ledButton-5.py



Resultat:

 


 

Problem.

Mitt första exemplar har jag inte kunnat boota.
Orsaken visade sig bero på för lågt versionsnummer på operativsystemet (Raspbian)
Raspberry Pi 3A+ kräver Raspbian versionen är 4.14 (2018-11-13) eller senare.
Mitt andra exemplar fungerade direkt.

 


Till början.